root/branches/nondb/ez_setup.py @ 454

Revision 454, 8.8 KB (checked in by arthur, 6 years ago)

update setuptools to latest

  • Property svn:keyword set to id
Line 
1#!python
2"""Bootstrap setuptools installation
3
4If you want to use setuptools in your package's setup.py, just include this
5file in the same directory with it, and add this to the top of your setup.py::
6
7    from ez_setup import use_setuptools
8    use_setuptools()
9
10If you want to require a specific version of setuptools, set a download
11mirror, or use an alternate download directory, you can do so by supplying
12the appropriate options to ``use_setuptools()``.
13
14This file can also be run as a script to install or upgrade setuptools.
15"""
16import sys
17DEFAULT_VERSION = "0.6c7"
18DEFAULT_URL     = "http://pypi.python.org/packages/%s/s/setuptools/" % sys.version[:3]
19
20md5_data = {
21    'setuptools-0.6b1-py2.3.egg': '8822caf901250d848b996b7f25c6e6ca',
22    'setuptools-0.6b1-py2.4.egg': 'b79a8a403e4502fbb85ee3f1941735cb',
23    'setuptools-0.6b2-py2.3.egg': '5657759d8a6d8fc44070a9d07272d99b',
24    'setuptools-0.6b2-py2.4.egg': '4996a8d169d2be661fa32a6e52e4f82a',
25    'setuptools-0.6b3-py2.3.egg': 'bb31c0fc7399a63579975cad9f5a0618',
26    'setuptools-0.6b3-py2.4.egg': '38a8c6b3d6ecd22247f179f7da669fac',
27    'setuptools-0.6b4-py2.3.egg': '62045a24ed4e1ebc77fe039aa4e6f7e5',
28    'setuptools-0.6b4-py2.4.egg': '4cb2a185d228dacffb2d17f103b3b1c4',
29    'setuptools-0.6c1-py2.3.egg': 'b3f2b5539d65cb7f74ad79127f1a908c',
30    'setuptools-0.6c1-py2.4.egg': 'b45adeda0667d2d2ffe14009364f2a4b',
31    'setuptools-0.6c2-py2.3.egg': 'f0064bf6aa2b7d0f3ba0b43f20817c27',
32    'setuptools-0.6c2-py2.4.egg': '616192eec35f47e8ea16cd6a122b7277',
33    'setuptools-0.6c3-py2.3.egg': 'f181fa125dfe85a259c9cd6f1d7b78fa',
34    'setuptools-0.6c3-py2.4.egg': 'e0ed74682c998bfb73bf803a50e7b71e',
35    'setuptools-0.6c3-py2.5.egg': 'abef16fdd61955514841c7c6bd98965e',
36    'setuptools-0.6c4-py2.3.egg': 'b0b9131acab32022bfac7f44c5d7971f',
37    'setuptools-0.6c4-py2.4.egg': '2a1f9656d4fbf3c97bf946c0a124e6e2',
38    'setuptools-0.6c4-py2.5.egg': '8f5a052e32cdb9c72bcf4b5526f28afc',
39    'setuptools-0.6c5-py2.3.egg': 'ee9fd80965da04f2f3e6b3576e9d8167',
40    'setuptools-0.6c5-py2.4.egg': 'afe2adf1c01701ee841761f5bcd8aa64',
41    'setuptools-0.6c5-py2.5.egg': 'a8d3f61494ccaa8714dfed37bccd3d5d',
42    'setuptools-0.6c6-py2.3.egg': '35686b78116a668847237b69d549ec20',
43    'setuptools-0.6c6-py2.4.egg': '3c56af57be3225019260a644430065ab',
44    'setuptools-0.6c6-py2.5.egg': 'b2f8a7520709a5b34f80946de5f02f53',
45    'setuptools-0.6c7-py2.3.egg': '209fdf9adc3a615e5115b725658e13e2',
46    'setuptools-0.6c7-py2.4.egg': '5a8f954807d46a0fb67cf1f26c55a82e',
47    'setuptools-0.6c7-py2.5.egg': '45d2ad28f9750e7434111fde831e8372',
48}
49
50import sys, os
51
52def _validate_md5(egg_name, data):
53    if egg_name in md5_data:
54        from md5 import md5
55        digest = md5(data).hexdigest()
56        if digest != md5_data[egg_name]:
57            print >>sys.stderr, (
58                "md5 validation of %s failed!  (Possible download problem?)"
59                % egg_name
60            )
61            sys.exit(2)
62    return data
63
64
65def use_setuptools(
66    version=DEFAULT_VERSION, download_base=DEFAULT_URL, to_dir=os.curdir,
67    download_delay=15
68):
69    """Automatically find/download setuptools and make it available on sys.path
70
71    `version` should be a valid setuptools version number that is available
72    as an egg for download under the `download_base` URL (which should end with
73    a '/').  `to_dir` is the directory where setuptools will be downloaded, if
74    it is not already available.  If `download_delay` is specified, it should
75    be the number of seconds that will be paused before initiating a download,
76    should one be required.  If an older version of setuptools is installed,
77    this routine will print a message to ``sys.stderr`` and raise SystemExit in
78    an attempt to abort the calling script.
79    """
80    try:
81        import setuptools
82        if setuptools.__version__ == '0.0.1':
83            print >>sys.stderr, (
84            "You have an obsolete version of setuptools installed.  Please\n"
85            "remove it from your system entirely before rerunning this script."
86            )
87            sys.exit(2)
88    except ImportError:
89        egg = download_setuptools(version, download_base, to_dir, download_delay)
90        sys.path.insert(0, egg)
91        import setuptools; setuptools.bootstrap_install_from = egg
92
93    import pkg_resources
94    try:
95        pkg_resources.require("setuptools>="+version)
96
97    except pkg_resources.VersionConflict, e:
98        # XXX could we install in a subprocess here?
99        print >>sys.stderr, (
100            "The required version of setuptools (>=%s) is not available, and\n"
101            "can't be installed while this script is running. Please install\n"
102            " a more recent version first.\n\n(Currently using %r)"
103        ) % (version, e.args[0])
104        sys.exit(2)
105
106def download_setuptools(
107    version=DEFAULT_VERSION, download_base=DEFAULT_URL, to_dir=os.curdir,
108    delay = 15
109):
110    """Download setuptools from a specified location and return its filename
111
112    `version` should be a valid setuptools version number that is available
113    as an egg for download under the `download_base` URL (which should end
114    with a '/'). `to_dir` is the directory where the egg will be downloaded.
115    `delay` is the number of seconds to pause before an actual download attempt.
116    """
117    import urllib2, shutil
118    egg_name = "setuptools-%s-py%s.egg" % (version,sys.version[:3])
119    url = download_base + egg_name
120    saveto = os.path.join(to_dir, egg_name)
121    src = dst = None
122    if not os.path.exists(saveto):  # Avoid repeated downloads
123        try:
124            from distutils import log
125            if delay:
126                log.warn("""
127---------------------------------------------------------------------------
128This script requires setuptools version %s to run (even to display
129help).  I will attempt to download it for you (from
130%s), but
131you may need to enable firewall access for this script first.
132I will start the download in %d seconds.
133
134(Note: if this machine does not have network access, please obtain the file
135
136   %s
137
138and place it in this directory before rerunning this script.)
139---------------------------------------------------------------------------""",
140                    version, download_base, delay, url
141                ); from time import sleep; sleep(delay)
142            log.warn("Downloading %s", url)
143            src = urllib2.urlopen(url)
144            # Read/write all in one block, so we don't create a corrupt file
145            # if the download is interrupted.
146            data = _validate_md5(egg_name, src.read())
147            dst = open(saveto,"wb"); dst.write(data)
148        finally:
149            if src: src.close()
150            if dst: dst.close()
151    return os.path.realpath(saveto)
152
153def main(argv, version=DEFAULT_VERSION):
154    """Install or upgrade setuptools and EasyInstall"""
155
156    try:
157        import setuptools
158    except ImportError:
159        egg = None
160        try:
161            egg = download_setuptools(version, delay=0)
162            sys.path.insert(0,egg)
163            from setuptools.command.easy_install import main
164            return main(list(argv)+[egg])   # we're done here
165        finally:
166            if egg and os.path.exists(egg):
167                os.unlink(egg)
168    else:
169        if setuptools.__version__ == '0.0.1':
170            # tell the user to uninstall obsolete version
171            use_setuptools(version)
172
173    req = "setuptools>="+version
174    import pkg_resources
175    try:
176        pkg_resources.require(req)
177    except pkg_resources.VersionConflict:
178        try:
179            from setuptools.command.easy_install import main
180        except ImportError:
181            from easy_install import main
182        main(list(argv)+[download_setuptools(delay=0)])
183        sys.exit(0) # try to force an exit
184    else:
185        if argv:
186            from setuptools.command.easy_install import main
187            main(argv)
188        else:
189            print "Setuptools version",version,"or greater has been installed."
190            print '(Run "ez_setup.py -U setuptools" to reinstall or upgrade.)'
191
192
193
194def update_md5(filenames):
195    """Update our built-in md5 registry"""
196
197    import re
198    from md5 import md5
199
200    for name in filenames:
201        base = os.path.basename(name)
202        f = open(name,'rb')
203        md5_data[base] = md5(f.read()).hexdigest()
204        f.close()
205
206    data = ["    %r: %r,\n" % it for it in md5_data.items()]
207    data.sort()
208    repl = "".join(data)
209
210    import inspect
211    srcfile = inspect.getsourcefile(sys.modules[__name__])
212    f = open(srcfile, 'rb'); src = f.read(); f.close()
213
214    match = re.search("\nmd5_data = {\n([^}]+)}", src)
215    if not match:
216        print >>sys.stderr, "Internal error!"
217        sys.exit(2)
218
219    src = src[:match.start(1)] + repl + src[match.end(1):]
220    f = open(srcfile,'w')
221    f.write(src)
222    f.close()
223
224
225if __name__=='__main__':
226    if len(sys.argv)>2 and sys.argv[1]=='--md5update':
227        update_md5(sys.argv[2:])
228    else:
229        main(sys.argv[1:])
230
231
232
233
234
Note: See TracBrowser for help on using the browser.