Ticket #18 (closed defect: worksforme)

Opened 10 years ago

Last modified 10 years ago

Walleye page access mysql problem

Reported by: fedroa Owned by: [email protected]
Priority: major Milestone:
Component: Honeywall Version: 1.3b1
Keywords: walleye Cc:

Description

After the roo1.3 install process was finished.

I have start the walleye web UI funcation.

but when I access the URL that " https://ip/", it happens.

The IE reponse is : Error Page

Cannot connect to the database Access denied for user 'admin'@'localhost' (using password: YES)

why?

Change History

Changed 10 years ago by rmcmillen

Can you describe what you have done to or on the honeywall prior to access the web page and getting the error?

Changed 10 years ago by fedroa

I just had re-configured the system via interview option. Then Set up the manage ip.

But now I have reolve this problem.

Detail: I found the start failed and connect mysql error information on console which hflowDB process. so i want to check the USER table of mysql.

The problem that i didnot found the roo and admin account record in user table of mysql. It maybe will cause init mysql constructure failed.

So I add roo and admin account into user table; then: mysql> update user set password=password('honey') where user='admin'; mysql> update user set password=password('honey') where user='roo';

At the end, I have to re-constructure the mysql databases via copy from roo1.0 mysql.

like this: mysql> show databases; +--------------------+ | Database | +--------------------+ | information_schema | | mysql | | test | | walleye_0_3 | | walleye_users_0_3 | +--------------------+ 5 rows in set (0.01 sec)

I think roo1.3 install problem have critical bug on mysql init process.

Can you confirm it? Maybe I'm make a mistake. :)

If you have any suggestion, please let me known. or mail to: [email protected]

Changed 10 years ago by rmcmillen

Let me make sure I understand what you do to get this error. You had already configured the honeywall via some other means. You then went back to the dialog menu and did the interview a second time and that is when it failed?

I am asking because I built a fresh honeywall from the 1.3 iso on the web, and I configured it using the dialog interview menu. Did not get any errors after I completed the interview.

Did you by any chance exit the menu with control-c?

Changed 10 years ago by rmcmillen

  • status changed from new to closed
  • resolution set to worksforme

Closing because I could not reproduce. Will reopen if it is reported again.

Note: See TracTickets for help on using tickets.